Alerts [Control Systems] Multiple Data Distribution Service Implementations Security Advisory

Number: AV21-586
Date: 15 November 2021

On 11 November 2021 ICS-CERT published an ICS Advisory to highlight vulnerabilities in the following products:

  • Eclipse CycloneDDS - versions prior to 0.8.0
  • eProsima Fast DDS - versions prior to 2.4.0 (#2269)
  • GurumNetworks GurumDDS - all versions
  • Object Computing, Inc. (OCI) OpenDDS - versions prior to 3.18.1
  • Real-Time Innovations (RTI) Connext DDS Professional and Connext DDS Secure - versions 4.2x to 6.1.0
  • RTI Connext DDS Micro - version 3.0.0 and later
  • TwinOaks Computing CoreDX DDS - versions prior to 5.9.1

Exploitation of these vulnerabilities could result in remote code execution, denial-of-service or information disclosure.

The Cyber Centre encourages users and administrators to review the provided web link, perform the suggested mitigations and apply the necessary updates where available.

ICS Advisory (ICSA-21-315-02)
https://us-cert.cisa.gov/ics/advisories/icsa-21-315-02

Note to Readers

The Canadian Centre for Cyber Security (Cyber Centre) operates as part of the Communications Security Establishment. We are Canada’s national authority on cyber security and we lead the government’s response to cyber security events. As Canada's national computer security incident response team, the Cyber Centre works in close collaboration with government departments, critical infrastructure, Canadian businesses and international partners to prepare for, respond to, mitigate, and recover from cyber events. We do this by providing authoritative advice and support, and coordinating information sharing and incident response. The Cyber Centre is outward-facing, welcoming partnerships that help build a stronger, more resilient cyber space in Canada.

 

Date modified: